Investing Issue

Incident Report for Cash App

Resolved

We've resolved an issue that was preventing some customers with Round Ups enabled from purchasing stocks using their Cash App Card. Stock purchases are now working normally for all customers. Thanks for your patience.
Posted Apr 30, 2026 - 09:42 PDT

Update

We're investigating an issue preventing some customers with Round Ups enabled from purchasing stocks using their Cash Card. Thank you for your patience while we look into this.
Posted Apr 29, 2026 - 08:06 PDT

Update

We're investigating an issue preventing some customers with Round Ups enabled from purchasing stocks using their Cash Card. Thank you for your patience while we look into this.
Posted Apr 29, 2026 - 08:05 PDT

Investigating

We're investigating an issue preventing some customers with Round Ups enabled from purchasing stocks using their Cash Card. Thank you for your patience while we look into this.
Posted Apr 29, 2026 - 07:43 PDT
This incident affected: Cash App Card, Investing, and In-App Alert.