Connection Issues

Incident Report for Cash App

Resolved

The connection issues affecting payments and login services have been fully resolved. Any payments that were previously pending have been successfully processed. Any new payments will now complete as expected. We appreciate your patience as we worked to resolve this.
Posted Jul 28, 2025 - 05:11 PDT

Monitoring

We've applied a resolution for the issue affecting payments and logins. Some customers may still be experiencing difficulties, but we'll provide an update as soon as we confirm the issue is resolved.
Posted Jul 25, 2025 - 19:28 PDT

Investigating

We're currently investigating reports of connection issues impacting payments and logins. Please do not re-attempt any payments while we look into this. Thanks for your patience in the meantime.
Posted Jul 25, 2025 - 18:51 PDT
This incident affected: Send & Receive Money and In-App Alert.