The connection issues affecting our lending services have been restored, all services are now operating normally. Thank you for your patience as we worked to resolve this issue.
Posted Jul 24, 2025 - 11:03 PDT
Identified
We've identified the cause of the connection issues affecting our lending services. Our engineering team is actively implementing a fix, and we'll share updates as soon as we have more information. While we don't have an estimated time for completion yet, we appreciate your patience and understanding.
Posted Jul 23, 2025 - 11:19 PDT
Investigating
We're investigating connection issues affecting our lending services. Our engineering team is working to resolve this, and we'll share updates as soon as we have more information. While we don't have an estimated time for resolution yet, we appreciate your patience and understanding in the meantime.