Cash App Connection Issues
Incident Report for Cash App
Resolved
We've resolved the outage affecting multiple Cash App features. Thank you for your patience.
Posted Nov 12, 2024 - 15:40 PST
Investigating
We're investigating reports of an outage impacting multiple Cash App features. Thanks for your patience, we'll provide an update soon.
Posted Nov 12, 2024 - 15:36 PST
This incident affected: Send & Receive Money, Cash App Card, Cash App Pay, Direct Deposit, Mobile Check Deposit, Add Cash, and In-App Alert.